{ Computer }

Montag, 15. Januar 2018

Die Hackerbibel | Computer

Aus irgendeinem Grund ist mir die "Hackerbibel" des Chaos Computer Clubs eingefallen, von der es zwei Bände gibt, die hier (Band 1) und hier (Band 2) ins Internet gestellt wurden. Empfehlenswert! Mein Favorit: "Batch Magic" von John DeHaven. Ich habe mir meinen ersten Computer - einen Commodore C-64 - ja 1986 gekauft, als Computern noch ein Abenteuer war. Nach meinen ersten Erfahrungen mit Commodore BASIC habe ich dann mit einer sehr guten Anleitung (auf Diskette) von Sybex 6510-Assembler gelernt.

Sonntag, 7. Januar 2018

Ubuntu | Computer

Ich bin so froh, dass ich - mittlerweile seit etwa vierzehn Jahren - Ubuntu-Linux habe. Ich möchte wirklich nicht mehr zu Windows zurück! So um 2002 habe ich mir meine erste Linux-Distribution installiert; das war damals SuSE 7.3. Zum Lernen hatte ich - sicherheitshalber - parallel noch Windows 98 laufen, das ich dann aber irgendwann deinstalliert habe.

Freitag, 5. Januar 2018

Wieder Probleme | Computer

Ich habe Joomla! nochmal neu installiert, weil das Backend auf Englisch war und ich keine Option entdeckt habe, das zu ändern. Nun, nachdem ich neu installiert habe, habe ich diese Option zwar gefunden, bekam, als ich die Sprachunterstützung German DE installieren wollte, aber folgende Fehlermeldung:
Warning
JFTP: :connect: Could not connect to host ' 127.0.0.1 ' on port ' 21 '
Error
Unable to find install package

Langsam frage ich mich, ob ich mir das weiter antun und nicht statt dessen das deutlich einfachere WordPress nehmen soll.

Donnerstag, 4. Januar 2018

Success!!! :-) | Computer

Login-Bildschirm von "Djangology"

So, nach vielem Rumprobieren hat es endlich geklappt: Ich habe Joomla! erfolgreich installiert und bekomme auch den Login-Bildschirm meiner neuen Site Djangology angezeigt. :-)

Jetzt geht es daran, die Features von Joomla! zu entdecken und ein bischen rumzuprobieren. Das Interface sieht auf den ersten Blick aber recht mager aus, und ich frage mich, wie man/frau damit Webseiten erstellen will.

Interface von Joomla!:

Interface von Joomla!

Joomla! installieren | Computer

Fehlermeldung bei der Joomla!-Installation

So, ich habe die Joomla!-Dateien per Midnight Commander in /var/www/html/joomla kopiert, und beim Aufruf von localhost/joomla ist sofort der Web-Installer gekommen. Ich habe dann alle erforderlichen Felder ausgefüllt; nur am Schluß - im letzten Schritt "Überblick" - bekam ich obige Fehlermeldung (ganz unten rot markiert). Ich habe also der fraglichen Datei configuration.php Lese- und Schreibrechte für root gegeben, aber die Fehlermeldung kam immer noch. Jetzt habe ich gelesen, dass ich für Apache2 CGI aktivieren muss. Wie das aber geht, das muß ich noch googeln.

Ich habe nun gelesen, dass ich die httpd.conf1 editieren muss. Mein Problem ist nur, dass ich sie nicht finde, weder im Joomla!-Verzeichnis noch in /etc/apache2. Jetzt habe ich entdeckt, dass ich mittels a2enmod unter Ubuntu Module laden kann.

Ich habe sicherheitshalber den Cache in Firefox geleert und Firefox neu gestartet, aber die Fehlermeldung kommt immer noch.

Ich habe jetzt nochmal ganz von vorn angefangen, aber wenn ich (ich werde dazu aufgefordert) das Joomla!-Installationsverzeichnis lösche, bekomme ich bei 'localhost/joomla' nur 'Error'. :-(
1 Diese Datei heißt bei mir apache2.conf. Da ist aber keine Option LoadModules vorhanden.

Probleme mit LibreOffice Writer | Computer

fehlerhaftes PDF

So sieht ein im LibreOffice Writer exportiertes PDF aus, wenn ich als Schrift 'Trebuchet MS' angebe1. Absolut mysteriös. Ich sage mir aber: So ist das Leben! Ein Problem ist gelöst, schon taucht ein neues auf. Ich habe spaßeshalber mal meine Django-Reinhardt-Biografie, um die es hier geht, als .rtf in LibreOffice Draw importiert und dort als PDF exportiert, aber da bekomme ich genau dasselbe! :-(
1 Der Font im PDF ist 'Spinner'. Wie das kommt, kann ich auch nicht sagen.

Und so sollte das PDF aussehen:



In der Online-Hilfe von LibreOffice Writer lese ich etwas von PDF-Optionen, aber wo sind die? Bei Launchpad finde ich eine Fehlerbeschreibung, in der exakt dieselben Fehler beschreiben sind, die ich auch habe.

Zitat:
"Actual Results: - In the PDF file, some characters are shifted together. Other characters such as capital letters are replaced by question marks."

Mittwoch, 3. Januar 2018

Es funktioniert! | Computer

Anmelde-Bildschirm für phpMyAdmin

So, mit 'localhost/phpmyadmin' kann man/frau sich bei gestartetem Apache2 (geht mittels '/etc/init.d/apache2 restart
'
) bei phpMyAdmin anmelden und so die für ein CMS erforderliche Datenbank administrieren. Jetzt muß ich mich noch mit Joomla auseinandersetzen.

Dienstag, 2. Januar 2018

Ubuntu: Probleme mit einem Paket | Computer

Wie ich via ubuntu-forum.de erfahren habe, liegt das Problem, das ich akut mit Linux habe, gar nicht an dem Paket phpMyAdmin. Da ich auf meinen letzten Beitrag in diesem Forum bis jetzt aber keine Antwort erhalten habe, bleibt mir nur noch, morgen meinen Schwager zu fragen, ob er eine Lösung weiß.

Montag, 1. Januar 2018

phpMyAdmin | Computer

Vor meinem Spaziergang wollte ich eigentlich den von mir installierten phpMyAdmin starten, bekam beim Aufruf von 'http://localhost/phpmyadmin' aber nur eine Fehlermeldung. Jetzt trinke ich erst mal eine Tasse Kaffee.

Wußte nicht, was ich machen soll und habe daher phpMyAdmin deinstalliert und dann erneut installiert, obwohl das nicht so elegant ist. Bekam folgende Fehlermeldung:
dpkg: Fehler beim Bearbeiten des Paketes initramfs-tools (--configure):
Unterprozess installiertes post-installation-Skript gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
initramfs-tools
Tja, da muß ich nochmal googeln.

P.S.: Ich habe jetzt im Ubuntu-Forum gepostet und warte auf Antwort.

Samstag, 30. Dezember 2017

Fehlermeldung | Computer

Wenn ich in den letzten Tagen CinePaint mittels 'sudo cinepaint' starten wollte, bekam ich immer die für mich mysteriöse Fehlermeldung 'sudo: Hostname ubuntu kann nicht aufgelöst werden'. Ais ich nach der Fehlermeldung gegoogelt habe, bin ich auf folgende Seite bei ubuntuusers.de gestoßen und habe herausgefunden, dass 'ubuntu' nicht in der Datei /etc/hosts eingetragen war. Meine Vermutung: Als ich XAMPP installiert habe, muß der Eintrag 'ubuntu' gelöscht worden sein. Ich habe also in /etc/hosts die Zeile '127.0.1.1 ubuntu' hinzugefügt. Seitdem ist die Fehlermeldung weg!

User Status

Du bist nicht angemeldet.

Blog-Suche

 

by-nc-nd
Januar 2018
Mo
Di
Mi
Do
Fr
Sa
So
22
23
24
25
26
27
28
29
30
31
 
 
 
 
 
 

Status

Online seit 4519 Tagen
Zuletzt aktualisiert: 21. Jan, 06:23

Aktuelle Beiträge

Google Chrome
Um Websites in möglichst vielen verschiedenen...
claus_01 - 21. Jan, 06:23
04:33 Uhr
Ich bin schon zum zweiten oder dritten Mal aufgewacht...
claus_01 - 21. Jan, 05:47
Gitarre spielen
So, und vor dem Schlafengehen habe ich nochmal "Clair...
claus_01 - 20. Jan, 21:40
Django Reinhardts Stücke...
Ich habe heute im Forum von DjangoBooks einen Beitrag...
claus_01 - 20. Jan, 21:23
Entdeckung
Heute abend habe ich zu meiner großen Überraschung...
claus_01 - 20. Jan, 21:15

Credits

knallgrau

antville

helma

sorua

twoday-net

twoday-agb

rss-feed

Blogverzeichnis - Bloggerei.de


Alternatives
Blogs
Comics
Computer
Copyright
Design
Eigene Texte
Film und Fernsehen
Forschung
Fotografie
Geschichte
Gesellschaft
Gitarre
Grafik
Hardware
Impressum
... weitere
Profil
Abmelden
Weblog abonnieren